请选择 进入手机版 | 继续访问电脑版
正在上传图片(0/1)

Mobile SDK激活问题

 0
手机看帖 17 4132
需要添加以下代码来进行激活验证,这段代码添加到哪里?
捕获.PNG
评论
上传
你需要登录之后才能回帖    登录 | 注册
yasenhu   2015-8-15 2#
https://github.com/DJI-Mobile-SDK/Android-FPVDemo-Part1
自己把demo下下来看看吧
DJI-XCJ   2015-8-16 3#
在我们SDK官方网站, dev.dji.com里面登陆个人账号根据你的应用名和appid申请一个API_KEY。

获得这个KEY之后请将其放到AndroidManifest.xml,一个名为com.dji.sdk.API_KEY的meta-data tag中。打开你的应用和设备互联网接入。

如果获得激活结果为0,那么证明已经激活成功
楼主   2015-8-16 4#
DJI-XCJ 发表于 2015-8-16 14:10
在我们SDK官方网站, dev.dji.com里面登陆个人账号根据你的应用名和appid申请一个API_KEY。

获得这个KEY之 ...
谢谢您的帮助,遇到点新问题:API KEY已经申请到并且填写到里面了,但是激活之前packge无法识别,就像下图,无法生成APP发到平板上,怎么连接设备激活呢?


捕获.PNG
楼主   2015-8-16 5#
yasenhu 发表于 2015-8-15 23:20
https://github.com/DJI-Mobile-SDK/Android-FPVDemo-Part1
自己把demo下下来看看吧
谢谢,已经下下来看好几遍了,并没有写的很详细
lanyusea  Inspire 1认证用户 2015-8-16 6#
Qingyan 发表于 2015-8-16 14:54
谢谢,已经下下来看好几遍了,并没有写的很详细
你好像没有装 Android SDK…
SDK板块日常维护志愿者。
我没有QQ,我也不接受私信提问。有问题请去论坛发帖,利人利己。

我没有QQ,我没有QQ,我没有QQ。
重要的事情说三遍。
yasenhu   2015-8-17 7#
Qingyan 发表于 2015-8-16 14:53
谢谢您的帮助,遇到点新问题:API KEY已经申请到并且填写到里面了,但是激活之前packge无法识别,就像下 ...
你没安装Android SDK 22
lianghao4688   2015-8-17 8#
你按照官方给的例子做,按照步骤昨晚,你就能理解应该在哪一步激活了。你要是还不明白的话可以看看demo,demo里是在哪个步骤做的,你按照做就可以了。http://dev.dji.com/cn/products/s ... d-fpv-demo-tutorial
lianghao4688   2015-8-17 9#
Qingyan 发表于 2015-8-16 14:53
谢谢您的帮助,遇到点新问题:API KEY已经申请到并且填写到里面了,但是激活之前packge无法识别,就像下 ...
看起来错误是因为你没安装22,但是看你的图片,怎么都没有导包啊。你先将包导进来,然后看看是什么错误。
wxjdjsdk   2015-8-17 10#
DJI-XCJ 发表于 2015-8-16 14:10
在我们SDK官方网站, dev.dji.com里面登陆个人账号根据你的应用名和appid申请一个API_KEY。

获得这个KEY之 ...
只把API_KEY加到android value后面就行了,其他的不用动是吗?
DJI-XCJ   2015-8-17 11#
wxjdjsdk 发表于 2015-8-17 11:29
只把API_KEY加到android value后面就行了,其他的不用动是吗?
把网络打开,打开APP即可
DJI-XCJ   2015-8-17 12#
Qingyan 发表于 2015-8-16 14:53
谢谢您的帮助,遇到点新问题:API KEY已经申请到并且填写到里面了,但是激活之前packge无法识别,就像下 ...
从Eclipse的提示信息来看,你应该是没有导入android-sdk-22.
请下载或更新此API包,然后再次尝试。
wxjdjsdk   2015-8-17 13#
DJI-XCJ 发表于 2015-8-17 11:58
把网络打开,打开APP即可
那个包名不用填进去吗?
楼主   2015-8-17 14#
wxjdjsdk 发表于 2015-8-17 14:21
那个包名不用填进去吗?
不用的
楼主   2015-8-17 15#
lanyusea 发表于 2015-8-16 19:03
你好像没有装 Android SDK…
谢啦,已解决~ ~
楼主   2015-8-17 16#
yasenhu 发表于 2015-8-17 00:00
你没安装Android SDK 22
谢啦,已解决~ ~
楼主   2015-8-17 17#
lianghao4688 发表于 2015-8-17 09:08
看起来错误是因为你没安装22,但是看你的图片,怎么都没有导包啊。你先将包导进来,然后看看是什么错误。 ...
谢啦,已解决~ ~
楼主   2015-8-17 18#
DJI-XCJ 发表于 2015-8-17 12:00
从Eclipse的提示信息来看,你应该是没有导入android-sdk-22.
请下载或更新此API包,然后再次尝试。
...
谢啦,已解决~ ~
收藏 点赞 评论
分享至:
回复:
上传
取消 评论
快速回复 返回顶部 返回列表