请选择 进入手机版 | 继续访问电脑版
正在上传图片(0/1)

问一个低级一点的问题

 0
手机看帖 6 3107
我是在windows下做Qt开发的,我从网上下的DJI_Onboard_API_Windows_QT_Sample代码
使用qt4.8.6+vs2010编译出错。
有编译成功的吗。

评论
上传
你需要登录之后才能回帖    登录 | 注册
skyzhou   2015-9-9 2#
QT是在5.3.2+mingw下开发的, 用了一些5.0版本后才有的类,所以用4.8.6版本编译时无法通过的。
楼主   2015-9-9 3#
skyzhou 发表于 2015-9-9 10:53
QT是在5.3.2+mingw下开发的, 用了一些5.0版本后才有的类,所以用4.8.6版本编译时无法通过的。 ...
只用了qt5.3.2的串口类,我把那个串口下载下来了,并引用了,编译通过了。打开串口功能都正常,但是点击激活时,程序报错。
skyzhou   2015-9-9 4#
具体报错内容是啥?
X43A   2015-9-9 5#
你重现下一遍,会不会是以前的样例有问题???
楼主   2015-9-9 6#
skyzhou 发表于 2015-9-9 14:23
具体报错内容是啥?
http://bbs.dji.com/forum.php?mod ... peid%26typeid%3D182
楼主   2015-9-9 7#
X43A 发表于 2015-9-9 14:38
你重现下一遍,会不会是以前的样例有问题???
样例是新的,刚打开会有一大片头文件错误,已及各种依赖错误,我把那些错误都排除了,能编译通过,就是点击激活时出错。提示 内存错误,程序就挂了。
收藏 点赞 评论
分享至:
回复:
上传
取消 评论
快速回复 返回顶部 返回列表