请选择 进入手机版 | 继续访问电脑版
正在上传图片(0/1)

PFVDemo和GSDemo的LIB库不能共用

 0
手机看帖 6 15056
我导入了FPVDemo和相应压缩包里的LIB,这个时候GSDemo工程中的DJIDrone.checkPermission(getApplicationContext(), new DJIGerneralListener()是报错的如果我导入GSDemo中的LIB,这个时候FPVDemo中的相应位置是报错的,不知道咋回事



评论
上传
你需要登录之后才能回帖    登录 | 注册
楼主   2016-1-11 2#
The method checkPermission(Context, DJIGeneralListener) in the type DJIDrone is not applicable for the arguments (Context, new DJIGerneralListener(){})   出了这个错误 不知道为什么,貌似FPVDemo和GSDemo两个工程的LIB不一样 两者不可得兼,怎么解决我想把两个功能一起用起来
楼主   2016-1-11 3#
android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views.   还报了这个错误
lanyusea  Inspire 1认证用户 2016-1-11 4#
应该有一个demo的库是旧的忘记更新了。
你直接下载最新的lib用应该就好,把报错的那个根据文档或者ide的提示改一下调用方式。
SDK板块日常维护志愿者。
我没有QQ,我也不接受私信提问。有问题请去论坛发帖,利人利己。

我没有QQ,我没有QQ,我没有QQ。
重要的事情说三遍。
楼主   2016-1-11 5#
请问我如何切换FPVDemo和GSDemo两个activity的功能?我切换界面就用了Intent好像一直报错android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views.
zqf123cn   2016-1-14 6#
1. Lib库的问题你应该使用的不同版本的Lib库,所以才会出现不兼容的情况。楼主只需要更新最新的Lib库使用即可。
2. 页面跳转使用Intent就可以正常实现的,没有什么特殊要求。请自己检查下代码。

另外,Mobile SDK已经发布3.0版本,楼主可以学习使用一下。
skywalkergod   2016-1-14 7#
zqf123cn 发表于 2016-1-14 14:56
1. Lib库的问题你应该使用的不同版本的Lib库,所以才会出现不兼容的情况。楼主只需要更新最新的Lib库使用即 ...
使用AS为什么都闪退?

收藏 点赞 评论
分享至:
回复:
上传
取消 评论
快速回复 返回顶部 返回列表